30 lines
614 B
Bash
30 lines
614 B
Bash
# Copyright 1999-2022 Gentoo Authors
|
|
# Distributed under the terms of the GNU General Public License v2
|
|
|
|
EAPI=7
|
|
|
|
inherit toolchain-funcs
|
|
|
|
DESCRIPTION="Coreutils Viewer: show progress for cp, rm, dd, and so forth"
|
|
HOMEPAGE="https://github.com/Xfennec/progress"
|
|
SRC_URI="https://github.com/Xfennec/progress/archive/v${PV}.tar.gz -> ${P}.tar.gz"
|
|
|
|
LICENSE="GPL-3"
|
|
SLOT="0"
|
|
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
|
|
|
|
RDEPEND="sys-libs/ncurses:="
|
|
DEPEND="${RDEPEND}"
|
|
BDEPEND="virtual/pkgconfig"
|
|
|
|
src_prepare() {
|
|
default
|
|
|
|
tc-export CC
|
|
}
|
|
|
|
src_install() {
|
|
emake PREFIX="${ED}/usr" install
|
|
dodoc README.md
|
|
}
|