app-arch/7zip: add 24.05
This commit is contained in:
parent
bf4d81f3eb
commit
200095bb6d
109
app-arch/7zip/7zip-24.05.ebuild
Normal file
109
app-arch/7zip/7zip-24.05.ebuild
Normal file
@ -0,0 +1,109 @@
|
||||
# Copyright 2023-2024 Gentoo Authors
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
|
||||
EAPI=8
|
||||
|
||||
inherit edos2unix flag-o-matic toolchain-funcs
|
||||
|
||||
NO_DOT_PV=$(ver_rs 1- '')
|
||||
DESCRIPTION="Free file archiver for extremely high compression"
|
||||
HOMEPAGE="https://www.7-zip.org/ https://sourceforge.net/projects/sevenzip/"
|
||||
# linux-x64 tarball is only used for docs
|
||||
SRC_URI="
|
||||
https://downloads.sourceforge.net/sevenzip/7-Zip/${PV}/7z${NO_DOT_PV}-src.tar.xz
|
||||
https://downloads.sourceforge.net/sevenzip/7-Zip/${PV}/7z${NO_DOT_PV}-linux-x64.tar.xz
|
||||
"
|
||||
S="${WORKDIR}"
|
||||
|
||||
LICENSE="LGPL-2 BSD rar? ( unRAR )"
|
||||
SLOT="0"
|
||||
KEYWORDS="~amd64"
|
||||
IUSE="uasm jwasm rar"
|
||||
REQUIRED_USE="?? ( uasm jwasm )"
|
||||
|
||||
DOCS=( readme.txt History.txt License.txt )
|
||||
HTML_DOCS=( MANUAL )
|
||||
|
||||
DEPEND="${RDEPEND}"
|
||||
BDEPEND="
|
||||
uasm? ( dev-lang/uasm )
|
||||
jwasm? ( dev-lang/jwasm )
|
||||
"
|
||||
|
||||
PATCHES=(
|
||||
"${FILESDIR}/${P}-respect-build-env.patch"
|
||||
)
|
||||
|
||||
# TODO(NRK): also build and install the library
|
||||
# TODO(NRK): make it so this package can be used as a drop-in replacement
|
||||
# for app-arch/p7zip ??
|
||||
|
||||
pkg_setup() {
|
||||
# instructions in DOC/readme.txt, Compiling 7-Zip for Unix/Linux
|
||||
# TLDR; every combination of options (clang|gcc)+(asm/noasm)
|
||||
# has a dedicated makefile & builddir
|
||||
mfile="cmpl"
|
||||
if tc-is-clang; then
|
||||
mfile="${mfile}_clang"
|
||||
bdir=c
|
||||
elif tc-is-gcc; then
|
||||
mfile="${mfile}_gcc"
|
||||
bdir=g
|
||||
else
|
||||
die "Unsupported compiler: $(tc-getCC)"
|
||||
fi
|
||||
if use jwasm || use uasm ; then
|
||||
mfile="${mfile}_x64"
|
||||
bdir="${bdir}_x64"
|
||||
fi
|
||||
export mfile="${mfile}.mak"
|
||||
export bdir
|
||||
}
|
||||
|
||||
src_prepare() {
|
||||
# patch doesn't deal with CRLF even if file+patch match
|
||||
# not even with --ignore-whitespace, --binary or --force
|
||||
pushd "./CPP/7zip" || die "Unable to switch directory"
|
||||
edos2unix ./7zip_gcc.mak ./var_gcc{,_x64}.mak ./var_clang{,_x64}.mak
|
||||
sed -i -e 's/-Werror //g' ./7zip_gcc.mak || die "Error removing -Werror"
|
||||
popd >/dev/null || die "Unable to switch directory"
|
||||
|
||||
default
|
||||
}
|
||||
|
||||
src_compile() {
|
||||
pushd "./CPP/7zip/Bundles/Alone2" || die "Unable to switch directory"
|
||||
|
||||
# avoid executable stack when using uasm/jwasm, harmless otherwise
|
||||
append-ldflags -Wl,-z,noexecstack
|
||||
export G_CFLAGS=${CFLAGS}
|
||||
export G_CXXFLAGS=${CXXFLAGS}
|
||||
export G_LDFLAGS=${LDFLAGS}
|
||||
|
||||
local args=(
|
||||
-f "../../${mfile}"
|
||||
CC=$(tc-getCC)
|
||||
CXX=$(tc-getCXX)
|
||||
)
|
||||
# NOTE: makefile doesn't check the value of DISABLE_RAR_COMPRESS, only
|
||||
# whether it's defined or not. so in case user has `rar` enabled
|
||||
# DISABLE_RAR_COMPRESS (and DISABLE_RAR) needs to stay undefined.
|
||||
if ! use rar; then
|
||||
# disables non-free rar code but allows listing and extracting
|
||||
# non-compressed rar archives
|
||||
args+=( DISABLE_RAR_COMPRESS=1 )
|
||||
fi
|
||||
if use jwasm; then
|
||||
args+=( USE_JWASM=1 )
|
||||
elif use uasm; then
|
||||
args+=( MY_ASM=uasm )
|
||||
fi
|
||||
|
||||
emake ${args[@]}
|
||||
popd > /dev/null || die "Unable to switch directory"
|
||||
}
|
||||
|
||||
src_install() {
|
||||
dobin "./CPP/7zip/Bundles/Alone2/b/${bdir}/7zz"
|
||||
einstalldocs
|
||||
}
|
2
app-arch/7zip/Manifest
Normal file
2
app-arch/7zip/Manifest
Normal file
@ -0,0 +1,2 @@
|
||||
DIST 7z2405-linux-x64.tar.xz 1553872 BLAKE2B d6c0bd4eb81f4112bfe50bf6affc68021b03d059076af5519a41c8d471e978ad2b4acc8f67c650070f9d07c518741a0146579ddfb8d56fd125f6db0beece0990 SHA512 13f97236157e2761a0bf406b08fba13a1ecc6d5663fb38f8dfe3b87f3910ba34fd359d8b36bea5135319543f31ec1e210eb512ea9864d9b140c336b9e416c313
|
||||
DIST 7z2405-src.tar.xz 1486772 BLAKE2B 609c7ae8b89e56e747ebfecb25108d8918138f48f0f2ed73183c76101ddd3615aafb9eb7823be0de2a434b450587e01f476d2ed092628a311b6e4ed091e06260 SHA512 d340adfa68e818dd3d3aa411780c81532fa37b6649178b81ec3739725f83e0bc3c01744612b2d467f4d0c2cc984dd35488406d7baee185cf372acebd9c0123a7
|
44
app-arch/7zip/files/7zip-24.05-respect-build-env.patch
Normal file
44
app-arch/7zip/files/7zip-24.05-respect-build-env.patch
Normal file
@ -0,0 +1,44 @@
|
||||
Respect build environment settings
|
||||
|
||||
Bug: https://bugs.gentoo.org/913186
|
||||
Bug: https://bugs.gentoo.org/913188
|
||||
Bug: https://bugs.gentoo.org/913189
|
||||
|
||||
|
||||
--- a/CPP/7zip/7zip_gcc.mak
|
||||
+++ b/CPP/7zip/7zip_gcc.mak
|
||||
@@ -103,14 +103,14 @@ SHARED_EXT=.dll
|
||||
LDFLAGS = -shared -DEF $(DEF_FILE) $(LDFLAGS_STATIC)
|
||||
else
|
||||
SHARED_EXT=.so
|
||||
-LDFLAGS = -shared -fPIC $(LDFLAGS_STATIC)
|
||||
+LDFLAGS = -shared -fPIC $(G_LDFLAGS) $(LDFLAGS_STATIC)
|
||||
CC_SHARED=-fPIC
|
||||
endif
|
||||
|
||||
|
||||
else
|
||||
|
||||
-LDFLAGS = $(LDFLAGS_STATIC)
|
||||
+LDFLAGS = $(LDFLAGS_STATIC) $(G_LDFLAGS)
|
||||
# -z force-bti
|
||||
# -s is not required for clang, do we need it for GCC ???
|
||||
|
||||
@@ -169,7 +169,7 @@ endif
|
||||
|
||||
|
||||
|
||||
-CFLAGS = $(MY_ARCH_2) $(LOCAL_FLAGS) $(CFLAGS_BASE2) $(CFLAGS_BASE) $(FLAGS_FLTO) $(CC_SHARED) -o $@
|
||||
+CFLAGS = $(MY_ARCH_2) $(LOCAL_FLAGS) $(CFLAGS_BASE2) $(CFLAGS_BASE) $(FLAGS_FLTO) $(CC_SHARED) $(G_CFLAGS) -o $@
|
||||
|
||||
|
||||
ifdef IS_MINGW
|
||||
@@ -209,7 +209,7 @@ CXX_WARN_FLAGS =
|
||||
#-Wno-invalid-offsetof
|
||||
#-Wno-reorder
|
||||
|
||||
-CXXFLAGS = $(MY_ARCH_2) $(LOCAL_FLAGS) $(CXXFLAGS_BASE2) $(CFLAGS_BASE) $(FLAGS_FLTO) $(CXXFLAGS_EXTRA) $(CC_SHARED) $(CXX_WARN_FLAGS) $(CXX_STD_FLAGS) $(CXX_INCLUDE_FLAGS) -o $@
|
||||
+CXXFLAGS = $(MY_ARCH_2) $(LOCAL_FLAGS) $(CXXFLAGS_BASE2) $(CFLAGS_BASE) $(FLAGS_FLTO) $(CXXFLAGS_EXTRA) $(CC_SHARED) $(CXX_WARN_FLAGS) $(CXX_STD_FLAGS) $(CXX_INCLUDE_FLAGS) $(G_CXXFLAGS) -o $@
|
||||
|
||||
STATIC_TARGET=
|
||||
ifdef COMPL_STATIC
|
Loading…
Reference in New Issue
Block a user